News: Welcome to ERCHA forums
Pages: [1]
  Print  
Author Topic: Programing Castle Phoenix Ice 100  (Read 24076 times)
Freeskiken
ErchaExecutive
Hero Member
*
Offline Offline

Posts: 267


View Profile
« on: January 14, 2011, 08:31:43 PM »

Hi,
1st. night
I was trying to setup my T-Rex 600 FBL. With BL600M Motor 1220 KV 6 Pole, 14 Tooth Pinion, Stock Gear Main 170 Tooth, WR Super BEC set at 6 volt, Castle Link Quick Connect, WR Glitch Buster, V Bar 5 Pro, Futaba R6008HS receiver, Futaba 10 CHG 2.4 G Transmitter, 6s 22.2 Volt 5000 mah Battery, 3 - Align DS610 Cyclic Servos, Futaba BLS254 Tail Servo, WR LED Tail Step Down 5.2 Volt. I went in a programed the ESC with the caslte link. (Governed Mode) I cant get the ESC to arm. When I hook up power it beep 6 times for the cells but no beep to arm. I went in to the TX and reversed throttle. I adjusted the low stick endpoints up and down but no beep. I went into the setting I have for my Raptor 50E and it was set to 89 / 120. So I went back and adjusted the TRex settings the same but still no beep. What am I doing wrong ? Also I could only set the head speed to #1 1800 RPM, #2 1900 RPM, #3 1900 RPM. If I went higher it said it was too high to governor ?

Thank you

Ken
« Last Edit: January 14, 2011, 08:35:14 PM by Freeskiken » Logged
Freeskiken
ErchaExecutive
Hero Member
*
Offline Offline

Posts: 267


View Profile
« Reply #1 on: January 14, 2011, 08:32:05 PM »

2nd night
I was reading the PDF from Castle and it shows for the calibration step to pick "Fixed Endpoints" in the Throttle tab in the Castle software program. I did not do this. I will try again

Logged
Freeskiken
ErchaExecutive
Hero Member
*
Offline Offline

Posts: 267


View Profile
« Reply #2 on: January 14, 2011, 08:34:15 PM »

3 rd. night
Still no luck. I am thinking I will try and rebind my receiver and see if this helps. I removed it from the same Helicopter (before complete rebuild) and it functions the servos so I thought it is not necessary but I am running out of ideas. I may try and remove the WR Glitch Buster but then I will have to cut the red wire to disable the ESC internal BEC. I have to install a 15 or 16 tooth pinion as well. Thanks Ken
« Last Edit: January 14, 2011, 08:36:33 PM by Freeskiken » Logged
Dmitry
ErchaMember
Sr. Member
*
Offline Offline

Posts: 95


View Profile
« Reply #3 on: January 14, 2011, 10:00:20 PM »

Try to lower throttle atv lower point. It could be way lower than 100.

Bring it to indoors tomorrow. I'll help you.
Logged
Freeskiken
ErchaExecutive
Hero Member
*
Offline Offline

Posts: 267


View Profile
« Reply #4 on: January 14, 2011, 11:19:00 PM »

Hi, Dmitry  I lowered the high and low to 30 / 30 from 100 / 100 then slowly increased them to 140 but no beep. On the Futaba 10 CHG the end point adjustment values are between 0 and 140 for high and low. Could it be that I did not bind the receiver again ? I am not sure if I can make it to indoor Saturday or not yet. Thanks Ken
Logged
Dmitry
ErchaMember
Sr. Member
*
Offline Offline

Posts: 95


View Profile
« Reply #5 on: January 15, 2011, 10:58:46 AM »

That's strange that it is not working. I guess that something is wrong with Vbar settings. Bring it to indoor when you can.

P.S. "Lower than 100 for low point" - I meant going to 101-150.  Smiley Sorry for confusion.
Logged
Freeskiken
ErchaExecutive
Hero Member
*
Offline Offline

Posts: 267


View Profile
« Reply #6 on: January 15, 2011, 10:40:09 PM »

Hi, Dmitry

I found the problem. I removed the WR Glitch Buster and the power wire to the ESC. Then hooked it up to channel # 3 on my Futaba receiver. Then I was able to program the ESC. 

Thanks Ken
Logged
Pages: [1]
  Print  
 
Jump to: